Microsoft Excel is an electronic spreadsheet program, created by multiple highly skilled engineers from Microsoft. It enables users to organize, format, and calculate data with formulas using a spreadsheet system broken up by rows and column.

TOP 30 MICROSOFT EXCEL INTERVIEW QUESTIONS
What are we going to learn in this book:-

1. What is Microsoft Excel?.................................................................4
2. What is Ribbon in MS-Excel? ..........................................................4
3. How many rows and columns are there in Microsoft Excel 2003 and later versions?..5
4. Which option do we use to adjust the text within a cell and what is the procedure to do it? ........................................................................................................5
5. What is the shortcut to put the filter on data in Microsoft Excel 2013?..............7
6. How many report formats are available in Excel and what are their names?........7
7. What is the difference between function and formula in MS-Excel?......................8
8. What is the process of making a chart and why is it important to make it right? .....9
9. Is it possible to make Pivot Table using multiple sources of data? How? ............9
10. How we can split a column into 2 or more columns?...........................................11
11. What is a Dashboard and what are the important things we should keep in mind while creating a dashboard?.................................................................13
12. What is the easiest solution to reduce the file size? ........................................13
13. What is Syntax of Vlookup? ..............................................................14
14. How to select all the objects in the sheet? ..................................................14
15. What is IF function in Microsoft Excel? ..................................................14
16. What is the use of Name box? ....................................................................15
17. What is the use of Vlookup and how do we use it? ........................................16
18. How can we view the values in the right most column in Excel?.......................18
19. How can we merge multiple cells text strings in a cell? ..................................19
20. What is Sumif function and how to use it? ..................................................21
21. What is Countif function and how to use it? ................................................23
22. What is Nested IF function? ......................................................................25
23. What is Pivot table and why we use it? .......................................................26
24. How to use advanced filter? ........................................................................27
25. How we can change the cell formatting? .....................................................29
26. What is conditional formatting and how to use it? .......................................30
27. How to make drop down list? .......................................................................33
28. How to make dynamic drop down list? ........................................................................34
29. How can we determine the day of the week for a particular date? .........................35
30. What is chart and how can we use it? ........................................................................36
Excel Interview Questions

Nowadays, there are various factors that are considered to select a candidate, such as Personality, Communication Skills, Attitude, Learning Skills etc. Now most of the industries seek one more skill that is Excel skill. These days, Excel usage has been increasing in the industry; individuals manage their data in Excel to analyze the business trend. If you are applying for jobs that require any sort of tracking, data or simple calculations, then before going for the interview, prepare yourself for those questions that are frequently asked by interviewers.

Here we present some questions and answers that are picked from real interviews:

Q1. What is Microsoft Excel?

Answer: Microsoft Excel is an electronic spreadsheet program, created by multiple highly skilled engineers from Microsoft. It enables users to organize, format, and calculate data with formulas using a spreadsheet system broken up by rows and column.

We also use this tool for storing, organizing and manipulating the data. In addition, it also offers programming that supports VBA, and we can use external database to make dynamic reports, analysis etc. Smart use of this program saves a lot of time and helps in creating our own applications too.

Q2. What is Ribbon in MS-Excel?

Answer: The ribbon in Excel consists of the tabs at the top. These tabs are split into groups which categorize related command buttons into sub tasks.

Each group has its respective command button and the dialog box launcher, which are present in the lower right corner in some of the groups.

This opens a dialog box containing a bunch of additional options we can choose from.
As per Excel’s default settings, we have 8 tabs. Which are:

- File
- Home
- Insert
- Page Layout
- Formulas
- Data
- Review
- View

Q3. How many rows and columns are there in Microsoft Excel 2003 and later versions?

Answer: Refer to the table below for the number of rows, columns and cells for Microsoft Excel 2003 & later version:

<table>
<thead>
<tr>
<th>Excel Versions</th>
<th>Rows</th>
<th>Columns</th>
<th>Total Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS Excel 2003</td>
<td>65536</td>
<td>256</td>
<td>16777216</td>
</tr>
<tr>
<td>MS Excel 2007</td>
<td>1048576</td>
<td>16384</td>
<td>17179869184</td>
</tr>
<tr>
<td>MS Excel 2010</td>
<td>1048576</td>
<td>16384</td>
<td>17179869184</td>
</tr>
<tr>
<td>MS Excel 2013</td>
<td>1048576</td>
<td>16384</td>
<td>17179869184</td>
</tr>
</tbody>
</table>

Q4. Which option do we use to adjust the text within a cell and what is the procedure to do it?

Answer: To adjust text in a cell, we use Wrap text option. It can be used in two ways:
Option 1: In the Home tab > Alignment > Wrap Text.

Option 2:
- Press Ctrl+1 on your keyboard
- Format cells dialog box will appear
- In the Alignment Tab
- Click on Wrap text
- And then click on OK
Q5. What is the shortcut to put the filter on data in Microsoft Excel 2013?

Answer: Ctrl+Shift+L is the shortcut key to put the filter in data.

You can find more shortcuts on the below links:


Q6. How many report formats are available in Excel and what are their names?

Answer: In Excel, we have three formats available:

- Compact
- Report
- Tabular
Q7. What is the difference between function and formula in MS-Excel?

Answer:

<table>
<thead>
<tr>
<th>Basis</th>
<th>Formula</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>A formula is a statement written by the user to be calculated.</td>
<td>A function is a piece of code designed to calculate specific values and are used inside formulas.</td>
</tr>
<tr>
<td>Location</td>
<td>A formula can be typed directly into the formula bar</td>
<td>A function cannot be typed as its built into the software</td>
</tr>
<tr>
<td>Nested</td>
<td>Formula cannot be nested</td>
<td>Functions can be nested</td>
</tr>
<tr>
<td>Complexity</td>
<td>Formulas are simple calculations</td>
<td>Functions are used to simplify complicated mathematics</td>
</tr>
<tr>
<td>Built-in wizard</td>
<td>Formulas do not have built-in wizards</td>
<td>A function often has a built-in wizard to help user complete them.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: Vlookup.</td>
</tr>
</tbody>
</table>

**Formula:-**

- `=A2+A3+A4`

  This is Formula, created by user

**Functions:-**

- `=SUM(A2:A4)`

  This is Function, built-in wizard
Q8. What is the process of making a chart and why is it important to make it right?

**Answer:** Chart is a medium to present the data in graphical visualization, and it is the most important insight of the data. To present the data with perfect visualization and appropriate information, we should always pre-decide on the information to be presented. We prepare the chart and then format it in presentable format.

Q9. Is it possible to make Pivot Table using multiple sources of data? How?

**Answer:** Yes, this is possible by using data modelling technique.

Start with collecting data from various sources:

- Import from a relational database, like Microsoft SQL Server, Oracle, or Microsoft Access. You can import multiple tables at the same time.
- Import multiple tables from other data sources including text files, data feeds, Excel worksheet data, and more. You can add these tables to the Data Model in Excel, create relationships between them, and then use the Data Model to create your PivotTable.

How to use Data Modelling for creating Pivot Table:

After creating relationships between tables, make use of the data for analysis.

- Click any cell on the worksheet
- Click Insert > PivotTable
• In the Create PivotTable dialog box, under Choose the data that you want to analyze, click Use an external data source.

![Create PivotTable dialog box]

• Click Choose Connection.
• On the Tables tab, in This Workbook Data Model, select Tables in Workbook Data Model.

![Existing Connections dialog box]

• Click Open, and then click OK to show a Field List containing all the tables in the Data Model.
Q10. How we can split a column into 2 or more columns?

Answer: To split the column into 2 or more columns, we use Text to column option.

Example: We have data in range E3:E8 and every cell contains three names with the space. We will follow below steps to split a column into 3 columns:

- Select the range E4:E8
- Press Alt, A, E on the keyboard
- Text to column dialog box will appear
- Step 1 of 3: Select Delimited, Step 2 of 3:- Click on Space, Step 3 of 3:- Select the destination (where we want to split data).
Click on OK
Q11. What is a Dashboard and what are the important things we should keep in mind while creating a dashboard?

**Answer:** Dashboard is a technique used to present important information through graphical representation. It is helpful in presenting huge data in a single computer screen so it can be monitored with a glance.

There are few things which should be taken care of, while preparing the dashboards:

1) Minimum distraction
2) Simple, easy to communicate
3) Important data
4) Few Colors
5) Relevant graphs
6) Dashboard should be on single computer screen

Q12. What is the easiest solution to reduce the file size?

**Answer:** Below are the steps to reduce the file size:

- Find the last cell that contains data in the sheet. Delete all rows and columns after this cell
- To delete the rows, press the key Shift+Space then press Ctrl+Shift+Down on your keyboard
- Rows will get selected till the last row. Press Ctrl+- on the keyboard to delete the blank rows
- To delete the column, Press the key Ctrl+Space then press Ctrl+Shift+Right Arrow key on your keyboard
- Columns will get selected till the last row
- Press Ctrl+- on the keyboard to delete the blank columns

Q13. What is Syntax of Vlookup?

**Answer:** Vlookup Syntax:

\[ =VLOOKUP(lookup\_value,table\_array,col\_index\_num,[range\_lookup]) \]

Q14. How to select all the objects in the sheet?

**Answer:** To select the object, we use Go to Special option.

Follow the below steps to select the objects:

- Press the shortcut key F5 to open the Go to Special dialog box
- Click on Special > Click on object > Click on OK
- All objects will get selected

Q15. What is IF function in Microsoft Excel?

**Answer:** ‘If function’ is one of the logical functions in Excel. We use this function to check the logical condition and specify the value whether it’s true or false. ‘If function’ has three arguments but only first argument is mandatory and other two are optional.
Q16. What is the use of Name box?

**Answer:** Name Box is located in the left most corner of the Excel sheet. Usually, we use Name box to check the cell reference to the active cell but it has several other uses too.

For Example: We can define the name of the range through Name box. Below are the steps to understand this statement:

- Select the range
- Edit in the Name box
- Type Weeks > Press Enter
Q17. What is the use of Vlookup and how do we use it?

**Answer:** Vlookup is used to find the data in the large spreadsheet by lookup value in another worksheet. To use the Vlookup function, we should have common values in both data. For example, we want to search the phone number of a person. So, in order to find out the phone number, we will need the concerned person’s name.

**How do we use it?**

We have 2 set of HR data in Excel. In the second data, we want to update joining date of every employee from the first data. To use the Vlookup function, data must have the common value.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1st Data Set</strong></td>
<td><strong>2nd Data Set</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Emp Code</td>
<td>Date Of Joining</td>
<td>Emp. Name</td>
<td>Designation</td>
<td>Emp Code</td>
</tr>
<tr>
<td>L1056</td>
<td>12-Jan-12</td>
<td>Employee 1</td>
<td>Executive</td>
<td>L2399</td>
</tr>
<tr>
<td>L1059</td>
<td>15-May-12</td>
<td>Employee 2</td>
<td>Manager</td>
<td>L2261</td>
</tr>
<tr>
<td>L1123</td>
<td>16-Sep-12</td>
<td>Employee 3</td>
<td>Sales Manager</td>
<td>L1951</td>
</tr>
<tr>
<td>L2261</td>
<td>18-Jan-13</td>
<td>Employee 4</td>
<td>Technical Head</td>
<td>L1813</td>
</tr>
<tr>
<td>L2399</td>
<td>22-May-13</td>
<td>Employee 5</td>
<td>Sr. Analyst</td>
<td>L1675</td>
</tr>
<tr>
<td>L1537</td>
<td>23-Sep-13</td>
<td>Employee 6</td>
<td>Executive</td>
<td>L1537</td>
</tr>
<tr>
<td>L1675</td>
<td>25-Jan-13</td>
<td>Employee 7</td>
<td>Chief Manager</td>
<td>L1123</td>
</tr>
<tr>
<td>L1813</td>
<td>29-May-13</td>
<td>Employee 8</td>
<td>Sales Manager</td>
<td>L1089</td>
</tr>
<tr>
<td>L1951</td>
<td>30-Sep-13</td>
<td>Employee 9</td>
<td>Technical Head</td>
<td>L1059</td>
</tr>
<tr>
<td>L1089</td>
<td>1-Feb-13</td>
<td>Employee 10</td>
<td>Sr. Analyst</td>
<td>L1056</td>
</tr>
<tr>
<td>L1022</td>
<td>5-Jun-13</td>
<td>Employee 11</td>
<td>Executive</td>
<td>L1022</td>
</tr>
</tbody>
</table>

**Follow below steps:-**
- Enter the formula in cell G3
- \(=\text{VLOOKUP}(F3,\$A\!3:\$D\!13,2,0)\)
- Press enter and copy the same formula in the range F4:F13

<table>
<thead>
<tr>
<th>Emp Code</th>
<th>Date Of Joining</th>
<th>Emp. Name</th>
<th>Designation</th>
</tr>
</thead>
<tbody>
<tr>
<td>L1056</td>
<td>12-Jan-12</td>
<td>Employee 1</td>
<td>Executive</td>
</tr>
<tr>
<td>L1059</td>
<td>15-May-12</td>
<td>Employee 2</td>
<td>Manager</td>
</tr>
<tr>
<td>L1123</td>
<td>16-Sep-12</td>
<td>Employee 3</td>
<td>Sales Manager</td>
</tr>
<tr>
<td>L2261</td>
<td>18-Jan-13</td>
<td>Employee 4</td>
<td>Technical Head</td>
</tr>
<tr>
<td>L2399</td>
<td>22-May-13</td>
<td>Employee 5</td>
<td>Sr. Analyst</td>
</tr>
<tr>
<td>L1537</td>
<td>23-Sep-13</td>
<td>Employee 6</td>
<td>Executive</td>
</tr>
<tr>
<td>L1675</td>
<td>25-Jan-13</td>
<td>Employee 7</td>
<td>Chief Manager</td>
</tr>
<tr>
<td>L1813</td>
<td>29-May-13</td>
<td>Employee 8</td>
<td>Sales Manager</td>
</tr>
<tr>
<td>L1951</td>
<td>30-Sep-13</td>
<td>Employee 9</td>
<td>Technical Head</td>
</tr>
<tr>
<td>L1089</td>
<td>1-Feb-13</td>
<td>Employee 10</td>
<td>Sr. Analyst</td>
</tr>
<tr>
<td>L1022</td>
<td>5-Jun-13</td>
<td>Employee 11</td>
<td>Executive</td>
</tr>
<tr>
<td>L2399</td>
<td>22-May-13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>L2261</td>
<td>18-Jan-13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>L1951</td>
<td>30-Sep-13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>L1089</td>
<td>1-Feb-13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>L1022</td>
<td>5-Jun-13</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Formula Explanation: \(=\text{VLOOKUP}(F3,\$A\!3:\$D\!13,2,0)\)

- In this formula, F3 is the cell of common value or lookup value
- Then we have selected the range \(\$A\!3:\$D\!13\) to the 1\textsuperscript{st} data
- 2: we have defined to pick the value from the 2\textsuperscript{nd} column
- 0: we have defined for the exact match
Q18. How can we view the values in the right most column in Excel?

**Answer:** We can view the value from the right most column through Index and Match function.

Example: We have 2 HR data in Excel. In the second data, we want to update joining date of every employee, from the first data. To use the Vlookup function, data must have the common value.

Follow below steps:-

- Enter the formula in cell G3
- \( =\text{INDEX($A$3:$D$13,MATCH(F3,$B$3:$B$13,0),1)} \)
- Press Enter
- Copy the formula in range G4:G13.
Formula Explanation: \( =\text{INDEX}(\$A\$3:\$D\$13,\text{MATCH}(F3,\$B\$3:\$B\$13,0),1) \)

- In this formula \( =\text{INDEX}(\$A\$3:\$D\$13 \text{ this syntax is used to define the array from which we want to pick the value} \)
- \( \text{MATCH}(F3,\$B\$3:\$B\$13,0) \text{ this syntax will help to lookup the value} \)
- At last '1 define' is to pick the value as result so 1 implies that we want to pick the value from the 1st column

**Q19. How can we merge multiple cells text strings in a cell?**

**Answer:** We can merge multiple cells text string by using the Concatenate function and “&” function.

Example: We have three names: First Name, Middle name, Last name in 3 columns. To merge the names and make it a full name, follow the steps below:
Concatenate Function

- Enter the formula in cell D2

"&" use in formula to merge the text:

- Enter the formula in cell E2
  - =A2"&"B2"&"C2
Q20. What is Sumif function and how to use it?

Answer: We use Sumif function to add the cells specified by a given condition or criterion.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Range</th>
<th>Criteria</th>
<th>Sum_Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>=SUMIF(range, criteria,[sum_range])</td>
<td>Data range from which we want to retrieve the sum</td>
<td>For which we want to calculate the sum from the data</td>
<td>The range of column from which we want calculate the sum</td>
</tr>
</tbody>
</table>

How to use it?

We have HR data in which we have salary details of every employee, department wise. Now, we want to retrieve the total salary amount department wise.
Follow these steps:

- Enter the formula in cell I2
  
- $=\text{SUMIF}(\$A2:\$E17,\$H2,\$E2:\$E17)$ and press Enter

- Copy the same formula in the range
Formula Explanation:

- \$A2:\$E17\ is the range of data
- \$H2\ is the criterion for which formula will calculate the sum
- \$,E2:\$E17\ is the sum range in the data

Q21. What is Countif function and how to use it?

Answer: We use Countif function to count the specified cells, with a given condition or criterion.
Example: We have HR data with salary details of every employee, department wise. Now, we want to count number of employees department wise.

- Enter the formula in cell I2
- =COUNTIF($A$2:$A$17,H2)
- Copy the same formula for the all manufacturer

**Few more examples:**

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Carid</th>
<th>Month</th>
<th>Year</th>
<th>Purchase Price</th>
<th>Manufacturer</th>
<th>Total Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mazda</td>
<td>46</td>
<td>Mar</td>
<td>FY-2010</td>
<td>$21,757</td>
<td>Mazda</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>35</td>
<td>Feb</td>
<td>FY-2013</td>
<td>$18,662</td>
<td>Toyota</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>35</td>
<td>Oct</td>
<td>FY-2011</td>
<td>$18,662</td>
<td>Volkswagen</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>35</td>
<td>Nov</td>
<td>FY-2010</td>
<td>$18,662</td>
<td>BMW</td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>46</td>
<td>Mar</td>
<td>FY-2010</td>
<td>$21,757</td>
<td>Peugeot</td>
<td></td>
</tr>
<tr>
<td>Volkswagen</td>
<td>37</td>
<td>Oct</td>
<td>FY-2010</td>
<td>$33,280</td>
<td>Honda</td>
<td></td>
</tr>
<tr>
<td>BMW</td>
<td>10</td>
<td>Oct</td>
<td>FY-2012</td>
<td>$64,584</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td>28</td>
<td>Mar</td>
<td>FY-2012</td>
<td>$28,050</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td>27</td>
<td>Mar</td>
<td>FY-2013</td>
<td>$22,572</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>34</td>
<td>Apr</td>
<td>FY-2012</td>
<td>$26,982</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Honda</td>
<td>39</td>
<td>Apr</td>
<td>FY-2010</td>
<td>$23,108</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>46</td>
<td>Apr</td>
<td>FY-2010</td>
<td>$21,757</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td>27</td>
<td>Sep</td>
<td>FY-2012</td>
<td>$22,572</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>46</td>
<td>May</td>
<td>FY-2013</td>
<td>$21,757</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>34</td>
<td>Nov</td>
<td>FY-2012</td>
<td>$26,982</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>46</td>
<td>Nov</td>
<td>FY-2011</td>
<td>$21,757</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Q22. What is Nested IF function?**

**Answer:** When we have multiple conditions to meet, we can make use of IF function 7 times, which is called Nested IF function.

Example: In cell A1, there is drop down list of A, B, C & D. If A is selected then cell B1 should return Excellent, on selection of B result should be good, for C result should be Bad and D should be poor.
Q23. What is Pivot table and why we use it?

**Answer:** Pivot table allows quick summarizing of large data. We can calculate the field and arrange the data in presentable way in just few minutes. Most of the Excel experts believe that Pivot table is the most powerful tool.

**Why do we use it?**

- Pivot table gives us flexibility and analytical power
- It is a time saver source in Excel
- Listing unique values in any column of a table
- Making a dynamic pivot chart
- Linking data sources outside excel and be able to make pivot reports out of such data
Q24. How to use advanced filter?

**Answer:** We use advanced filter to extract the unique list of items or we can extract the specific item from different worksheets. We can say that advanced filter is an advanced version of Auto filter.

Example: In a range, we have duplicate products and we want to filter only unique list.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Manufacturer</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Mazda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Toyota</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Toyota</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Toyota</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Mazda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Volkswagen</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>BMW</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Peugeot</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Peugeot</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Toyota</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Honda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Mazda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Peugeot</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Mazda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Toyota</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Mazda</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Follow below steps:

- Select the data range
- Go to Data tab > Click on Advanced
- Advanced dialog box will open
- Click on copy to another location
- Select the destination
- Click on OK

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manufacturer</td>
<td>Manufacturer</td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>Mazda</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>Toyota</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>Volkswagen</td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td>BMW</td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td>Peugeot</td>
<td></td>
</tr>
<tr>
<td>Volkswagen</td>
<td>Honda</td>
<td></td>
</tr>
<tr>
<td>BMW</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Honda</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peugeot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toyota</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mazda</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Excel sheet shows a list of car manufacturers with the first 18 rows extracted and the last row empty.

Advanced Filter dialog box is also shown with the 'Copy to another location' option selected and list range set to A1:A17 and criteria range set to $A$1:$A$17.

- Select 'Copy to another location' option
- Enter list range $A1:A17$
- Enter criteria range $A1:A17$
- Click OK
Q25. How we can change the cell formatting?

**Answer:** To change the cell formatting “Format cell” option is used.

Example: In cell A1, the value is to be converted into percentage, change the number appearance by following these steps:

- Press Ctrl+1 shortcut key to open Format cells dialog box
- In the number category, click on Percentage option
- Click on OK
Q26. What is conditional formatting and how to use it?

Answer: Conditional formatting is a tool that allows us to highlight the cells or range on the basis of few conditions and that formatting is always based on the values or text which can be automatically changed.

Example: In cell A1, there is a drop down list of A, B, C & D. If A is selected, then cell should be highlighted in green color, If B1 is selected then cell color should be blue, in case of C it should be yellow and if D is selected, then it should be highlighted in red color.

Follow these steps:

- Select the Cell A2
- Go to Home Tab > Conditional Formatting > New Rule > Use a formula to determine which cells to format
- Enter the formula in tab
- Click on Format > Format cells dialog box will appear > Fill tab > Choose color > Click on OK
- Follow the same procedure for the rest of the grades
Q27. How to make drop down list?

**Answer:** We make the drop down list by using the data validation in Microsoft Excel.

Example: We want to create weekday’s list in a cell.

Follow these steps:

Make the weekday’s list in column A.

Select the cell in which we want to create the drop down list.

- Go to Data tab > Data validation > Data Validation dialog box will open
- In Settings tab > List (Allow) > Source (Select the range A1:A8) > Click on ok
- In Cell C1, drop down list will be created
Q28. How to make dynamic drop down list?

**Answer:** To add item in the list, always create the dynamic list. This list picks the added value automatically and no editing is required within the list. To create dynamic drop down list, we use offset function along with Countif function.

Steps to create the dynamic list:

- Select the cell C1
- Go to the Data tab > Data Validation > Data Validation dialog box will appear
Q29. How can we determine the day of the week for a particular date?

**Answer:** By using the Weekday function, we can return to the day of the week of a particular date.

Example: In cell A1, its today’s date and we want to return the weekday and count from Sunday. Follow these steps:

- In the Settings tab > List (Allow)
- Enter the formula in formula box
- \( = \text{OFFSET}(A:A,1,0,\text{COUNTA}(A:A)-1,1) \)
- Click on OK
• Enter the formula in Cell B1
• =WEEKDAY(A1,1) press Enter
• Formula will return 3, it means today is 3rd day of the week

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>7/14/2015</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Q30. What is chart and how can we use it?**

**Answer:** Chart is the way to represent the data in graphical visualization. We can present the data in a more informative, easy to understand manner by using the chart. In Excel, we have 10 types of charts. Ex: - For representation of sales performance chart, bar chart is suitable.

Say, we have manufacturers’ data with purchase price. We want to see the contribution of every manufacturer; therefore, we will use pie chart.

• Select the data range
• Go to Insert tab > Charts > Select Pie Chart

In the above image, we can see very clearly that which manufacturer has contributed more than others and which manufacturer has contributed the least.