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Excel Interview Questions

Interviews are challenging. Job interviews that require any sort of tracking data or simple

calculations are even trickier, as this would require a knack of MS-Excel.

Excel usage has been increasing in the industry; individuals manage their data in Excel to

analyze the business trend

And, it could be nerve-wracking for both the interviewer and the interviewee to face such
questions. To prepare you for those frequently asked questions, here we present a library of

30 questions and answers picked from real interviews.
All the best!
Q1. What is Microsoft Excel?

Answer: Microsoft Excel is an electronic spreadsheet program, created by multiple highly
skilled engineers from Microsoft. It enables users to organize, format, and calculate data

with formulas using a spreadsheet system broken up by rows and column.

We also use this tool for storing, organizing and manipulating the data. In addition, it also
offers programming that supports VBA, and we can use external database to make dynamic
reports, analysis etc. Smart use of this program saves a lot of time and helps in creating our
own applications too.

Q2. What is Ribbon in MS-Excel?

Answer: The ribbon in Excel consists of the tabs at the top. These tabs are split into groups

which categorize related command buttons into sub tasks.

Each group has its respective command button and the dialog box launcher, which are

present in the lower right corner in some of the groups.

This opens a dialog box containing a bunch of additional options we can choose from.
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HOME IMSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW E

5 Q [?:n @ B New Window [l | ED'_J Ef:r

E Arrange All " [DI

Workbook Show  Zoom 100% Zoomto Switch Macros
Views = - Selection B Freeze Panes~ [ | B Windowe -

Zoom Window Macros S

As per Excel’s default settings, we have 8 tabs. Which are:

e File
e Home
e Insert

e Page Layout

e Formulas

e Data
e Review
e View

Q3. How many rows and columns are there in Microsoft Excel 2003 and later

versions?

Answer: Refer to the table below for the number of rows, columns and cells for Microsoft

Excel 2003 & later version:-

Excel Versions Rows Columns Total Cells
MS Excel 2003 65536 256 16777216
MS Excel 2007 1048576 16384 17179869184
MS Excel 2010 1048576 16384 17179869184
MS Excel 2013 1048576 16384 17179869184

Q4. Which option do we use to adjust the text within a cell and what is the
procedure to do it?

Answer: To adjust text in a cell, we use Wrap text option. It can be used in two ways:
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Option 1: In the Home tab > Alignment > Wrap Text.

HOME | INSERT  PAGELAYOUT  FORMULAS  DATA  REVIEW  VIEW D
s X A = o | B Conditional Formatting - B | #
Fg - E
paste O Fort Alignment Number L Format as Table Cells  Editing
Lo - - - [ CellStyles - - -
Clipboard 1 Styles ~
Al - 5P Wrap Text [ v
A = & [ Merge & Center - G " =
1] i ) Alignment 3 F
2 Wrap Text
3
. 1[Micraorie]| Wiep etra-long tetinio multiple
lines 50 you can see all of it
: V
5
; . ?E\d\(rt‘:soﬂ
. xcel
2
9
10
W @ Tellme more
12 =
QU0 | sheetz | shees | @ ¢ [ ] ]

Option 2:

e Press Ctrl+1 on your keyboard

e Format cells dialog box will appear
e In the Alignment Tab

e Click on Wrap text

e And then click on OK

. —
Format Cells @u

Mumber | Aliggment | Font IBu-n:IerI Fill |Pmtecliu-n

Text alignment Crrientation
Horizontal: - .
|Genera| El Indent: . ’_
Vertical: L= I .
| Bottom El x || T _¢
[ Justify distributed ! N

Text control .

|| Shrink to fit
Merge cells

Right-to-left
Text direction:

ot [

[ ok || cancel
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Check for more examples:

Automatically & manually wrapping text

Q5. What is the shortcut to put the filter on data in Microsoft Excel 2013?
Answer: Ctrl+Shift+L is the shortcut key to put the filter in data.
You can find more shortcuts on the below links:

e 250 Excel Keyboard Shortcuts
e The Best Shortcut Keys

Q6. How many report formats are available in Excel and what are their names?
Answer: In Excel, we have three formats available:

e Compact
e Report

e Tabular

Q7. What is the difference between function and formula in MS-Excel?

Answer:
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Basis Formula Function

A function is a piece of code

A formula is a statement written b . .
y designed to calculate specific values

Definition
the user to be calculated. .
and are used inside formulas.
Location A formula can be typed directly into A function cannot be typed as its
the formula bar built into the software
Nested Formula cannot be nested Functions can be nested
. . . Functions are used to simplify
Complexity Formulas are simple calculations . .
complicated mathematics

A function often has a built-in wizard

Built-in wizard | Formulas do not have built-in wizards to help user complete them.
Example: Vlookup.

Formula:-
SUM AR . SRV =A2+A3+AL
A | E C D E F G H I
1 |Number
2 12
3 14
4 56
5 :,.'.\2+A3+A4~ This is Formula, created by user
Functions:-
A | B C D E F G H I
1 Number
2 12
3 14
44 5 _ﬁ_
5:] :SUM[JJ.Z:;M}M This is Function, built-in wizard
3] SUM(numberl, [number2], ...)
7

Q8. What is the process of making a chart and why is it important to make it right?

Top 30 Microsoft Excel Interview Question

www.exceltip.com / www.excelforum.com



http://www.exceltip.com/
http://www.excelforum.com/

Answer: Chart is a medium to present the data in graphical visualization, and it is the most
important insight of the data. To present the data with perfect visualization and appropriate
information, we should always pre-decide on the information to be presented. We prepare

the chart and then format it in presentable format.

Understand Message to Prepare the Format the

the data be Conveyed Chart chart

Q9. Is it possible to make Pivot Table using multiple sources of data? How?
Answer: Yes, this is possible by using data modelling technique.
Start with collecting data from various sources:

e Import from a relational database, like Microsoft SQL Server, Oracle, or Microsoft
Access. You can import multiple tables at the same time.

e Import multiple tables from other data sources including text files, data feeds, Excel
worksheet data, and more. You can add these tables to the Data Model in Excel,
create relationships between them, and then use the Data Model to create your
PivotTable.

How to use Data Modelling for creating Pivot Table:
After creating relationships between tables, make use of the data for analysis.

e Click any cell on the worksheet
e Click Insert > PivotTable

E HOME INSERT
o = e
%
PivotTablejRecommended Table
PivotTables

Tables

¢ In the Create PivotTable dialog box, under Choose the data that you want to analyze,

click Use an external data source
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)
Create PivotTable B

Choose the data that you want to analyze

() Select a table or range
Table/Range: | |ﬁ|

Choose Connection.

Connection name:

oy

Choose where you want the PivotTable report to be placed
() New Worksheet
@ Existing Worksheet
Location: | Sheetl!SAS1
Choose whether you want to analyze multiple tables
Add this data to the Data Model

[ ok ][ cana |

e Click Choose Connection.

e On the Tables tab, in This Workbook Data Model, select Tables in Workbook Data
Model.

Select a Connection or Table

| Connections | Tables l

tov: TGN |

This Workbook Data Model "
Tables in Workbook Data Model
4 Table(s)

Testing_Data_Model
Orders

[Blank]

Product categories
[Blank]

Products

[Blank]

Salespeople v

B A A

Open Cancel

e Click Open, and then click OK to show a Field List containing all the tables in the
Data Model.

Q10. How we can split a column into 2 or more columns?

Answer: To split the column into 2 or more columns, we use Text to column option.
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Example: We have data in range E3:E8 and every cell contains three names with the space.
We will follow below steps to split a column into 3 columns:-

e Select the range E4:ES8
e Press Alt, A, E on the keyboard
e Text to column dialog box will appear

e Step 1 of 3: Select Delimited, Step 2 of 3:- Click on Space, Step 3 of 3:- Select the
destination (where we want to split data).

Convert Text to Columns Wizard - of 3 ? RS |
ety

The Text Wizard has determined that your data is Delimited.

If this is correct, choose Mext, or choose the data type that best describes your data,
Original data type
Choose the file type that best describes your data:
@) Delimited - Characters such as commas or tabs separate each field.
(71 Fixed width - Fields are aligned in columns with spaces between each field.

Preview of selected data:

Broncho Billy Anderson ol
WMilliam Lemuel Boyd

Mayor Tom Bradley

Pohn Drew Barrymore

Lauren Shuler Donner

oo [ oy Jen e

Cancel ]| < Back |[ Next > ][ Finish
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Convert Text to Columns Wizard - Step 2 of 3 &B

This screen lets you set the imiters your data ¢ i You can see how your text is affected
in the preview below,

Delimiters

Tab
Semicolon Treat consecutive delimiters as one

Comma -
e
omer. ||

Data preview
Broncho Billy PRnderson o
flilliam [Lemuel Boyd
Mayor [Com Bradley
Tohn Prew Barrymore
[Lzuren [Fhuler Donner -
£l 3
Cancel ] [ < Back ] [ medt- | [ Finish ]
i (2] = ]
Caonvert Text to Columns Wizard - Step 1 of 3 \ J

This screen lets you select each column and set the Data Format.
Column data format
@ General
() Text

Cowe wor [

(7) Do not import column {skip}

‘General’ converts numeric values to numbers, date values
to dates, and all remaining values to text.

Destination: | =5F54:5HS4

Data preview

Eradley
Barrymore
fonner -

[ cance | [ <gack || wea- | [ Enisn |

e Click on OK
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Text to column

Broncho Billy Anderson |Broncho Billy Anderson
William Lemuel Boyd William Lemuel Boyd
Mayor Tom Bradley Mayor Tom Bradley
John Drew Barrymore  |John Drew Barrymore
Lauren Shuler Donner |Lauren Shuler Donner

Q11. What is a Dashboard and what are the important things we should keep in

mind while creating a dashboard?

Answer: Dashboard is a technique used to present important information through graphical
representation. It is helpful in presenting huge data in a single computer screen so it can be

monitored with a glance.
There are few things which should be taken care of, while preparing the dashboards:

1) Minimum distraction

2) Simple, easy to communicate
3) Important data

4) Few Colors

5) Relevant graphs

6) Dashboard should be on single computer screen
Q12. What is the easiest solution to reduce the file size?
Answer: Below are the steps to reduce the file size:

e Find the last cell that contains data in the sheet. Delete all rows and columns after
this cell

e To delete the rows, press the key Shift+Space then press Ctrl+Shift+Down on your
keyboard

e Rows will get selected till the last row. Press Ctrl+- on the keyboard to delete the

blank rows

Top 30 Microsoft Excel Interview Question
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e To delete the column, Press the key Ctrl+Space then press Ctrl+Shift+Right Arrow
key on your keyboard
e Columns will get selected till the last row

e Press Ctrl+- on the keyboard to delete the blank columns
Q13. What is Syntax of Vlookup?

Answer: Vlookup Syntax:

=VLOOKUP(lookup_value,table_array,col_index_num,[range_lookup])

| =VLOOKUP{
VLOOKUPlookup_value, table_array, col_index_nurm, [range_loockup])

Q14. How to select all the objects in the sheet?
Answer: To select the object, we use Go to Special option.
Follow the below steps to select the objects:

e Press the shortcut key F5 to open the Go to Special dialog box
e Click on Special > Click on object > Click on OK

e All objects will get selected

FILE HOME  INSERT ~ PAGELAYOUT ~ FORMULAS  DATA  REVIEW

oy X A = o | | EE Conditional Farmatting &
D B3 - [7 Format as Table
Paste ¥

Font Alignment Number Cells  Editing

[57 Cell Styles

Clipboard 1= Styles ~

Q15. What is IF function in Microsoft Excel?

Answer: 'If function’ is one of the logical functions in Excel. We use this function to check
the logical condition and specify the value whether it's true or false. ‘If function’ has three

arguments but only first argument is mandatory and other two are optional.
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=IF{
| IF{logical_test, [value_if_true], [value_if false]) |

Q16. What is the use of Name box?

Answer: Name Box is located in the left most corner of the Excel sheet. Usually, we use

Name box to check the cell reference to the active cell but it has several other uses too.

For Example: We can define the name of the range through Name box. Below are the steps

to understand this statement:

e Select the range
e Edit in the Name box

e Type Weeks > Press Enter

FILE HOME IMSERT PAGE LAYOUT FORMULA!

o2 E B @ISR

Insert  AutoSurmn Recently Financial Logical Text Date & Lo
Function - Used - M M - Time~= Ref

Function Library

Weeks - ] *.,,;_I\" Name Box }5‘9’

' L M N 0 P
Sunday
Monday
Tuesday
Wednesday |

Wedne _—1 Range
Friday

Saturday

1
2
3
4
5
6
7
8
9
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Q17. What is the use of Vlookup and how do we use it?

Answer: Vlookup is used to find the data in the large spreadsheet by lookup value in
another worksheet. To use the Vlookup function, we should have common values in both
data. For example, we want to search the phone number of a person. So, in order to find

out the phone number, we will need the concerned person’s name.
How do we use it?

We have 2 set of HR data in Excel. In the second data, we want to update joining date of
every employee from the first data. To use the Vlookup function, data must have the

common value.

HOME  INSERT  PAGELAYOUT  FORMULAS  DATA  REVIEW | VEW | Sid)]
= Q [b*_} @ B2 New Window [l | ED'_J Ei_r
Workbook Show  Zoom lﬂfﬁé Zoom to S Arange Al o Switch Macras
Views - - Selection E=] Freeze Panes - [ Windows - -
Zoom Window Macros A
D13 - I w
A E C D E F G
1 1st Data Set 2nd Data Set
Date Of Emp

2 |Emp Code |loining Emp. Name |Designation Code |Date Of Joining

3 |L1056 12-Jan-12|Employee 1 |Executive L2399

4 L1059 15-May-12|Employee 2 |Manager L2261

5 L1123 16-Sep-12|Employee 3 |Sales Manager L1951

6 L2261 18-Jan-13(Employee 4 |Technical Head L1813

7 |L2359 22-May-13|Employee 5 |Sr. Analyst L1675

& L1537 23-5ep-13|Employee 6 |Executive L1537

9 |L1675 25-Jan-13|Employee 7 |Chief Manager L1123

10 |L1813 29-May-13|Employee 8 |Sales Manager L1089

11 L1951 30-Sep-13|Employee 9 |Technical Head L1059

12 |L1089 1-Feb-13|(Employee 10 |Sr. Analyst L1056

1= L1022 5-Jun-13|Employee 11 |Executive L1022

Follow below steps:-
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e Enter the formula in cell G3
¢ =VLOOKUP(F3,$A%$3:$D%$13,2,0)

e Press enter and copy the same formula in the range F4:F13

HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW Si
5 Q [E‘_} @ B Mew Window [l | EE Ef:r
Workbook Show  Zaom 100?6 Zoom to B Arange Al | Switch  Macros
Views ~ v Selection [ Freeze Panes - [ Windows - -
Zoom Window facros A
G3 v fe || =VLOOKUP(F3,5A53:5D513,2,0)
A B C D E F G H H
1 1st Data Set 2nd Data Set
Date Of Emp

2 |Emp Code |loining Emp. Name |Designation Code |Date Of Joining

3 L1056 12-Jan-12|Employee 1 |Executive L2399 22-May-13

4 |L1059 15-May-12|Employee 2 |Manager L2261 18-Jan-13

5 L1123 16-Sep-12|Employee 3 |Sales Manager L1951 30-Sep-13

6 |L2261 18-Jan-13|Employee 4 |Technical Head L1813 29-May-13

7 L2399 22-May-13|Employee 5 |Sr. Analyst L1675 25-Jan-13

g |L1537 23-5ep-13|Employee 6 |Executive L1537 23-Sep-13

9 |L1675 25-Jan-13|Employee 7 |Chief Manager L1123 16-5ep-12

10 |L1B13 29-May-13|Employee 8 |Sales Manager L1089 1-Feb-13

11 L1551 30-Sep-13|Employee 9 |Technical Head L1059 15-May-12

12 |L1089 1-Feb-13|Employee 10 [Sr. Analyst L1056 12-Jan-12

13 |L1022 5-Jlun-13|Employee 11 |Executive L1022 5-Jun-13

Formula Explanation: =VLOOKUP(F3,$A$3:$D$13,2,0)

e In this formula, F3 is the cell of common value or lookup value
e Then we have selected the range $A$3:$D$13 to the 1t data
e 2: we have defined to pick the value from the 2" column

e 0: we have defined for the exact match

www.exceltip.com / www.excelforum.com

Top 30 Microsoft Excel Interview Question



http://www.exceltip.com/
http://www.excelforum.com/

Q18. How can we view the values in the right most column in Excel?

Answer: We can view the value from the right most column through Index and Match
function.

Example: We have 2 HR data in Excel. In the second data, we want to update joining date
of every employee, from the first data. To use the Vlookup function, data must have the

common value.

FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW

e —
d Cut Calibri Ju Ky == ®-  EWepte

et ER Copy ~

aste - - - S == E S

- ¥ Format Painter g ru H & A - - — 1= = Merge & C

Clipboard Pl Font P Alignment
A2 | i 2 Date Of Joining
A B C D E F G H
1 1st Data Set 2nd Data Set
Date Of Emp |Date Of

2 | loining Emp Code |Emp. Name |Designation Code |loining
3 | 12-Jan-12|L1056 Employee 1 |Executive L2399
4 | 15-May-12|L1059 Employee 2 |Manager L2261
5 | 16-Sep-12|L1123 Employee 3 |Sales Manager L1951
6 | 18-lan-13|L2261 Employee 4 |Technical Head 11813
7 | 22-May-13|12399 Employee 5 |Sr. Analyst L1675
& | 23-5ep-13|L1537 Employee 6 |Executive L1537
9 | 25-Jan-13|L1675 Employee 7 |Chief Manager 11123
10 | 29-May-13|L1813 Employee 8 |Sales Manager L1089
11| 30-Sep-13|L1951 Employee 9 |Technical Head L1059
12| 1-Feb-13|L1089 Employee 10 |Sr. Analyst L1056
13| 5-Jun-13|L1022 Employee 11 |Executive L1022

Follow below steps:-

e Enter the formula in cell G3
e =INDEX($A$3:$D$13,MATCH(F3,$B$3:$B$13,0),1)
e Press Enter

e Copy the formula in range G4:G13.
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HOME | INSERT  PAGELAVOUT  FORMULAS  DATA  REVIEW  VIEW
“D ‘_%CUt Verdana v|8 '| AN == =| - E—f‘Wrap Text
ER Copy - ==
Pavste ~ Format Painter B L U 7 H- L-A- === & 3= [E Merge& Center
Clipboard ] Font ] Alignment
G3 vt Fe || =INDEX($A$3:3D$13,MATCH(F3,5B53:38513,0),1)
A B C D E F G H 1
1 1st Data Set 2nd Data Set
Date Of Emp |Date Of
2 Joining Emp Code |Emp. Name |Designation Code |Joining
3 | 12-Jan-12|L1056 Employee 1 |Executive 12399 (22-May-13
4 | 15-May-12|L1059 Employee 2 |Manager L2261 18-Jan-13
5 | 16-Sep-12(L1123 Employee 3 |Sales Manager L1951| 30-Sep-13
6 | 18-Jan-13|L2261 Employee 4 |Technical Head L1813 |29-May-13
7 | 22-May-13|L2399 Employee 5 |[Sr. Analyst L1675| 25-Jan-13
& | 23-5ep-13|L1537 Employee 6 |Executive L1537 | 23-5ep-13
9 | 25-Jan-13|L1675 Employee 7 |Chief Manager L1123 | 16-Sep-12
10 | 29-May-13|L1813 Employee 8 |Sales Manager L1089| 1-Feb-13
11| 30-Sep-13|L1951 Employee 9 |Technical Head L1059 |15-May-12
12 | 1-Feb-13|L1089 Employee 10 |5r. Analyst L1056 12-Jan-12
13| 5-Jun-13(L1022 Employee 11 [Executive L1022| 5-Jun-13

Formula Explanation: =INDEX($A$3:$D$13,MATCH(F3,$B$3:$B$13,0),1)

e In this formula =INDEX($A$3:$D$13 this syntax is used to define the array from
which we want to pick the value

e MATCH(F3,$B$3:$B$13,0) this syntax will help to lookup the value

e At last'l define’ is to pick the value as result so 1 implies that we want to pick the

value from the 1t column
Q19. How can we merge multiple cells text strings in a cell?

Answer: We can merge multiple cells text string by using the Concatenate function and “&”

function.

Example: We have three names: First Name, Middle name, Last name in 3 columns. To

merge the names and make it a full name, follow the steps below:
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Al - J= || First Name
A E C F G H I
1 |First Name |Middle Name |Last Name
2 |Broncho Billy Anderson
3 |William Lemuel Boyd
4 |Mayor Tom Bradley
5 |John Drew Barrymore
& |Lauren Shuler Donner
7
&

Concatenate Function

Enter the formula in cell D2
=CONCATENATE(A2," ",B2," ",C2)

D2 hd fe | =CONCATENATE(A2,"",B2,"",C2)
A B C D E F
1 |First Name |Middle Name |Last Name |Using Concatenate Formula |Using "&" Formula
2 |Broncho Billy Anderson Broncho Billy Anderson
3 |william Lemuel Boyd William Lemuel Boyd
4 |Mayor Tom Bradley Mayor Tom Bradley
5 |lohn Drew Barrymore  |John Drew Barrymaore
& |Lauren Shuler Donner Lauren Shuler Donner
7
@

“&" use in formula to merge the text:

Enter the formula in cell E2
=A2&" "&B2&" "&C2
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E2 | i I =p2&" "EB2&" "&(C2

A B C D E
1 |First Name |Middle Name |Last Name |Using Concatenate Formula |Using "&" Formula
2 |Broncho Billy Anderson Broncho Billy Anderson Broncho Billy Anderson
3 (william Lemuel Boyd William Lemuel Boyd William Lemuel Boyd
4 Mayor Tom Bradley Mayor Tom Bradley Mayor Tom Bradley
5 [lohn Drew Barrymore  |John Drew Barrymore John Drew Barrymore
& |Lauren Shuler Donner Lauren Shuler Donner Lauren Shuler Donner
7

Q20. What is Sumif function and how to use it?

Answer: We use Sumif function to add the cells specified by a given condition or criterion.

Criteria Sum_Range

The range of

=SUMIF(range, criteria,[sum_range]) Data range from For which we want column from which
which we want to to calculate the sum | we want calculate
retrieve the sum from the data the sum

How to use it?

We have HR data in which we have salary details of every employee, department wise.

Now, we want to retrieve the total salary amount department wise.
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FILE HOME IMSERT PAGE LAYOUT FORMULAS DATA REVIEW WIEW Sign in H

ﬂr_LI X Calibri v|11‘ - === 9 | EBConditional Formatting = | 24 | | gy
- Eg- B I U~ A A === - Nurmber ﬁFurmat as Table Cells Editing
¥ H- H-A- EZ3= B - 7 cellstyles- - -
Clipboard 1= Font P Alignment M Styles -
Al | I Manufacturer v
A B C D E F G H I J 4]
Manufact Purchase Manufactur |Total
1 |urer Carld Month  |Year Price er Price
2 |Mazda 46|Mar FY-2010 521,757 Mazda
3 |Toyota 35|Feb FY-2013 518,662 Toyota
4 |Toyota 35|0ct FY-2011 518,662 Volkswagen
5 Toyota 35|Nov Fy¥-2010 518,662 BMW
& Mazda 46| Mar Fy-2010 521,757 Peugeot
7 |Volkswag 37|0ct FY-2010 533,280 Honda
5 |BMW 10|O0ct FyY-2012 564,584
9 |Peugeot 28|Mar Fy-2012 528,060
10 Peugeot 27|Mar Fy-2013 522,572
11 Toyota 34|Apr Fy-2012 526,982
12 Honda 19|Apr Fy-2010 523,108
13 |Mazda 46|Apr Fy-2010 521,757
14 Peugeot 27|5ep FY-2012 522,572
15 |Mazda a6|May FY-2013 521,757 L
16 Toyota 34|Apr Fy-2012 526,982
17 |Mazda 46(Nov Fy-2011 521,757 -

Follow these steps:

e Enter the formula in cell 12
e =SUMIF($A$2:$E$17,$H2,$E$2:$E$17) and press Enter

e Copy the same formula in the range
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FILE HOME IMSERT PAGE LAYOUT FORMULAS DATA REVIEW YIEW Signiin

&D X% |Ca|ibri *lll‘ :| f f f o, %Cnnditiunal Formatting = ﬁ i
Paste BB B I UL AN SE=E L B FomatasTable- Cells Editing
.~ H- LA e 3= - - [Cdcellstyles~ - -
Clipboard Font T Alignment T Styles
12 | I =5L.|M|FI[Sr’-‘l.$2:$F$1?,$H2,$E$2:$E$1?}+SUMIF{$A$2:$F$1?,$H2,
$F$2:$F$1?}
A B C D E F G H I ]
Manufact Purchase Manufactur |Total
1 |urer Carld Month Year Price Discount er Price
2 |Mazda 46| Mar FY-2010 §21,757| 52,176 Mazda 5119,665
3 |Toyota 35|Feb FY-2013 518,662 51,866 Toyota 5120,944
4 |Toyota 35|0ct FY-2011 518,662 51,866 Volkswagen | 536,608
5 | Toyota 35| MNov Fy-2010 518,662 51,866 BMW 571,042
& |Mazda 4a(Mar Fy-2010 521,757 52,178 Peugeot 580,525
7 |Volkswag 37|0ct Fy-2010 533,280 53,328 Honda 525,418
& BMW 10| 0ct Fy-2012 564,584 56,458
9 |Peugeot 28|Mar Fy-2012 528,060 52,806
10 |Peugeot 27|Mar Fy-2013 522,572 52,257
11 (Toyota 34|Apr Fy-2012 526,982 52,698
12 |Honda 19)Apr Fy-2010 523,108| 52,311
13 |Mazda 46|Apr Fy-2010 §21,757| 52,176
14 |Peugeot 27|5ep Fy-2012 §22,572| 52,257
15 |Mazda 46|May Fy-2013 §21,757| 52,176

Formula Explanation:

o $A$2:$E$17it is the range of data
e $H2 is the criterion for which formula will calculate the sum
e ,$E$2:$E$17is the sum range in the data

Q21. What is Countif function and how to use it?

Answer: We use Countif function to count the specified cells, with a given condition or

criterion.
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Example: We have HR data with salary details of every employee, department wise. Now,

we want to count number of employees department wise.

HOME IMSERT PAGE LAYOUT FORMULAS DATA REVIEW WIEW Sign in '
-“-,__LI % |Calibri v|11A :| == 9 | EZConditional Formatting = | iz | | g§
- Eg- B I U- A §f === - Number @Furmat as Table~ Cells Editing
¥y H- &-A- & 3= - - [FcellStyles~ - -
Clipboard Font M Alignment M Styles
Al A Je Manufacturer
A B C D E F G H I
Purchase Total
1 |Manufacturer |Carld Month Year Price Manufacturer |Price
2 |Mazda 46|Mar FYy-2010 521,757 Mazda
3 |Toyota 35|Feb Fy-2013 518,662 Toyota
4 |Toyota 35|0ct Fy-2011 518,662 Volkswagen
5 |Toyota 35| Mov Fy-2010 518,662 BMW
& Mazda 46|Mar Fy-2010 521,757 Peugeot
7 Volkswagen 37|0ct Fy-2010 533,280 Honda
& |BMW 10{Oct Fy-2012 564,584
9 |Peugeot 28|Mar Fy-2012 528,060
10 |Peugeot 27|Mar Fy-2013 522,572
11 |Toyota 34|Apr Fy-2012 526,982
12 Honda 19|Apr Fy-2010 523,108
13 |Mazda 46| Apr FYy-2010 521,757
14 Peugeot 27|5ep Fy-2012 522,572
15 |Mazda 46|May Fy-2013 521,757
16 |Toyota 34|Apr Fy-2012 526,982
17 |Mazda 46|Mov Fy-2011 521,757

e Enter the formula in cell 12
e =COUNTIF($A$2:$A$17,H2)

e Copy the same formula for the all manufacturer
Few more examples:

1. COUNTIF in Microsoft Excel
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2. COUNT Functions: COUNT, COUNTA, COUNTIF and COUNTBLANK
3. How to use COUNT functions

Q22. What is Nested IF function?

Answer: When we have multiple conditions to meet, we can make use of IF function 7
times, which is called Nested IF function.

Example: In cell A1, there is drop down list of A, B, C & D. If A is selected then cell B1
should return Excellent, on selection of B result should be good, for C result should be Bad
and D should be poor.

Bl .| f | =IF[AL="A","Excellent”, IF(A1="B","Good", IF[A1="C","Bad",IF(A1="D","Very Bad™})))
A B C D E F G H | J K L

1A Excellent

2

Bl | 3 f =IF[a1="A","Excellent” IF{A1="B","Good",IF{A1="C","Bad", IF| A1="D","Very Bad"]}}})
A B C D E F G H I J K L

1 B Good

2

2

Bl - = =IF[a1="A" "Excellent™ IF{A1="B","Good™ IF{A1="C","Bad",IF[A1="D","Very Bad"}}})
A ] C D E F G H 1 1 K L

1|C Bad

Bl - = =IF[Aal="A","Excellent”, IF[Al="8","Good" IF{A1="C","Bad",IF[A1="D","Very Bad"])))

B C D E [ F G H I [ J [ K L
1|D Very Bad
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Q23. What is Pivot table and why we use it?

Answer: Pivot table allows quick summarizing of large data. We can calculate the field and
arrange the data in presentable way in just few minutes. Most of the Excel experts believe

that Pivot table is the most powerful tool.
Why do we use it?

e Pivot table gives us flexibility and analytical power

e Itis a time saver source in Excel

e Listing unique values in any column of a table

e Making a dynamic pivot chart

e Linking data sources outside excel and be able to make pivot reports out of such
data

Q24. How to use advanced filter?

Answer: We use advanced filter to extract the unique list of items or we can extract the
specific item from different worksheets. We can say that advanced filter is an advanced

version of Auto filter.

Example: In a range, we have duplicate products and we want to filter only unique list.
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Al | 2 Manufacturer

A B C D E

Manufacturer
Mazda
Toyota
Toyota
Toyota
Mazda
Volkswagen
BNW
Peugeot
Peugeot
Toyota
Honda
Mazda
Peugeot
Mazda
Toyota
Mazda

TR« R I T RN TV e

=
[

[ary
=

=
Fa

=
L

-
.

[y
Ln

=
h

[ury
]

Follow below steps:

e Select the data range

e Go to Data tab > Click on Advanced
e Advanced dialog box will open

e Click on copy to another location

e Select the destination
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- -
Adeanced Glieh |2 i)

Action

() Filter the list, in-place

@ iCopy to another location;
List range: | SAS1:54517
Criteria range: |
Copy to: scs1

Unique records only

| ok || canca |

e Click on OK

Extract v 2 Manufacturer

A B C D E F

Manufacturer Manufacturer
Mazda Mazda

Toyota Toyota
Toyota Volkswagen
Toyota BMW

Mazda Peugeot
Volkswagen Honda

BENW
Peugeot
Peugeot
Toyota
Honda
Mazda
Peugeot
Mazda
Toyota
Mazda

Woga =l Chown s Wk

—
L]

=
[y

—
-

—
L

-
I

=
n

—
o

=
]

—
[a4]
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Q25. How we can change the cell formatting?
Answer: To change the cell formatting “Format cell” option is used.

Example: In cell A1, the value is to be converted into percentage, change the number

appearance by following these steps:

e Press Ctrl+1 shortcut key to open Format cells dialog box

e In the number category, click on Percentage option

e Click on OK
FILE HOME  INSERT  PAGELAYOUT  FORMULAS = DATA REVIEW  VIEW

Ij% I:% I:% I:E} D ”1‘-’ 2] Connections El :E:‘:I E EE’ZI E

E :=| Properties

Frorn  From  From From Other Fuicting Bafrach Tl Snr Eiltar Tavttn Flach B
Access Web  Text Sources~ O Format Cells | ¥ 28 |
Get External Data
_ Number |Alignment | Font | Border | Fill | Pmtectiunl
Al -
_ Category:
A B C General | Sample
Mumber
Percentage
1 |Percentage Currency 9
Accounting Decimal places: |0 =
2 0.35 Date = p . IZ'
3 Time
4 Fraction
5 Scientific
Text
] Special
7 Custom
8
Q
10
11 -
12
132 Percentage formats multiply the cell value by 100 and displays the result with a percent symbaol.
14
15
16
17 [ ok || conce
15
L. &
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Q26. What is conditional formatting and how to use it?

Answer: Conditional formatting is a tool that allows us to highlight the cells or range on the

basis of few conditions and that formatting is always based on the values or text which can

be automatically changed.

Example: In cell A1, there is a drop down list of A, B, C & D. If A is selected, then cell
should be highlighted in green color, If B1 is selected then cell color should be blue, in case

of C it should be yellow and if D is selected, then it should be highlighted in red color.

FILE HOME INSERT PAGE LAYOUT FORMULAS E|

T A = o FZ Conditional Formattin

k] —
[Z7 Format as Table -
Clipboard  Font  Alignment Mumber «f Format as Table

- . - - [EFcCell styles-
Styles -~

A2 M K| A v

A | B C D E F
L | Grade

1
2|
3
q

Follow these steps:

e Select the Cell A2
e Go to Home Tab > Conditional Formatting > New Rule > Use a formula to determine

which cells to format
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@ @ %ﬂ: % ij 2 AutoSum -

y Fill -
Conditional Formatas Cell Insert Delete Format
Formatting= Table~ Styles~ - - - & Clear~
Styles Cells Edit
Conditional Formatting I
Easily spot trends and patterns in
@ your data using bars, colors, and R

icons to visually highlight important
walues.

O
@)
o

e =T - - ]

0 Tell me more

e Enter the formula in tab
e Click on Format > Format cells dialog box will appear > Fill tab > Choose color >
Click on OK

e Follow the same procedure for the rest of the grades
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New Formatting Rule

Select a Rule Type:

New Formatting Rule (9] = |

= Format all cells based on their values

= Farmatl only cells that contain

= Farmat only top or bottam ranked values

= Format only values that are above of below average
= Farmat only wnique or duplicate values

=I5 a formula to determing which cells to Tormat

Selet a Rule Type:

= Format all cells based on their walues

= Format only cells that contain

= Farmal only Lop or betlom ranked values

= Farmat only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Edut the Rule Description:
Formal values where this formula is trues

|=sa52="0" o)

- ==

[ cancer |

[ ok

Edit the Rule Description:
Format values where this formula is rue;

[ = sas5228°

e \_\ (Cromae)

ok || comeer |

New Formatting Rule | ¥ &

Select a Ruls Type:

Mew Formatting Rule (2] &

Select a Rule Type:

= Format all cells based on their values

= Format only cells that contain

= Formal anly tap ar battam ranked values

= Format only values that are above or beldw average
= Format only unique or duplicate values

= Lsg a formula to determine which cells bo Tormat

= Format all cells based on their values

= Farmat anly cells that contain

= Farmat anly top or bottom ranked values

= Format only values that are above or below average
= Farmal anly unigue or duplicate values

= Use a formula to determing which cells to format

Ediit the Rule Description:

Format values where this Tormula s trees

| =5a52mC

AaBbCctylz

Edit the Rule Description:

Format values wherg this Tommula is true:

=5482="D" (Fsil

Preview: [nrm]

oK ][um|]
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Q27. How to make drop down list?

Answer: We make the drop down list by using the data validation in Microsoft Excel.
Example: We want to create weekday’s list in a cell.

Follow these steps:

Make the weekday’s list in column A.

Select the cell in which we want to create the drop down list.

e Go to Data tab > Data validation > Data Validation dialog box will open
e In Settings tab > List (Allow) > Source (Select the range A1:A8) > Click on ok

e In Cell C1, drop down list will be created

|1

Data Validation [2] = |

Settings | Input Message | Error Alert |

Validation criteria

Allow:

|List [¥] 1gnare blank
Data: ln-cell dropdown
|between IZ|

Source:

[=sast:sass

Apply these changes to all other cells with the same settings

o ) [ana
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FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW

BB 5B B R o Vi & B

. Propertie: ) Y Reapply
Frern  From  From  From Other Existing Refresh o Il Sort Filter Textto  Flash
Access Web  Text Sources~  Connections  All~- [} Edit Links T Advanced Colurmns ~ Fill
Get External Data Connections Sort & Filter
c1 | fe || Monday
A B C | D E F G H 1 1

1 |Week Name Monday E
2 Sunday Week Name

sunda
3 |Monday

Tuesday
4 TUESdav Wednesday
5 |Wednesday Thursday

Friday
& |Thursday Saturday
7 |Friday
g | Saturday
3]

Q28. How to make dynamic drop down list?

Answer: To add item in the list, always create the dynamic list. This list picks the added
value automatically and no editing is required within the list. To create dynamic drop down

list, we use offset function along with Countif function.
Steps to create the dynamic list:

e Select the cell C1

e (o to the Data tab>Data Validation > Data Validation dialog box will appear
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FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW Sign in p

E‘ [ Connections | & 7 Yx Clear Y [E? Flash Fill iRl 53] Group ~ =
g & A . ; -
=~ Properties Yo Reapply B-ARemove Duplicates Ep- gg Ungroup ~ "=
Get External Refresh 7| Set  Fiter _ Tetto o -
Data = Al o Edit Links A Yo Acvanced  ¢oumns S Data Validation = =5 Ef subtotal
Connections Sort & Filter % Data Validation... Outline P B
Al M F || City Name E Cl"'EI”"'D o Validation v
1 E\% Clear Val
A B C o} E F G | Pick from a list of rules to limit the L
il (City Name .| tyg‘lle of data that can be entered in a
cell.
2 Guernsey
3 |Suriname For example, you can provide a list
4 Sudan of values, like 1, 2, and 3, or only
- - allow numbers greater than 1000 as
5 Micronesia valid entries.
6 |Japan
7 lamaica 0 Tell me more
8
9
10 -
> | Qo | Q17 | Q18 | Q9 | Q0 | Q2 | Q2 | Q2 | Qs | Q6 [ .. ® : AT ][]

H M o-—————+ 100%

e In the Settings tab >List (Allow)

e Enter the formula in formula box

e =0OFFSET(A:A,1,0,COUNTA(A:A)-1,1)
e Click on OK

Data Validation 2] % |

Settings | Input Message I Error Alert |

Validation criteria

Allowe:

st [7] ignare blank
Data: [#] 1n-cen dropdown
| between El

Source:

| =0FFSET(A:A, L0, COUNTA[AA)-LL)

Apply these changes to all other cells with the same settings

[ ok || cona |

Q29. How can we determine the day of the week for a particular date?

Answer: By using the Weekday function, we can return to the day of the week of a

particular date.

Example: In cell Al, its today’s date and we want to return the weekday and count from

Sunday. Follow these steps:
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e Enter the formula in Cell B1
e =WEEKDAY(A1,1) press Enter

e Formula will return 3, it means today is 3™ day of the week

B1 | Jfe || =WEEKDAY(A1,1)
A B C D E F G H I
1 |7/14/2015 3
2
3

Q30. What is chart and how can we use it?

Answer: Chart is the way to represent the data in graphical visualization. We can present
the data in a more informative, easy to understand manner by using the chart. In Excel, we

have 10 types of charts. Ex: - For representation of sales performance chart, bar chart is
suitable.

Say, we have manufacturers’ data with purchase price. We want to see the contribution of

every manufacturer; therefore, we will use pie chart.

e Select the data range
e Go to Insert tab > Charts > Select Pie Chart

HOME | INSERT  PAGELAVOUT ~ FORMULAS ~ DATA  REVIEW  VIEW Sign in
F2 Conditional Formatting ~ @ 4

- $-9% » [FFormatasTable~
8 8 [7 Cell Styles ~

) styles

Cells  Editing

5 Number

=
=
a
L
IDREARES

A B c D E F G H 1 J [~

Mazda $21,757) Chart Title

BMW 564,584
Peugeot $28,060]
Honda 523,108]

In the above image, we can see very clearly that which manufacturer has contributed more
than others and which manufacturer has contributed the least.
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