Chapter 7

Formulas

Entering a Formula into a Cell

Excel offers two options for entering a formula into a cell.
E Typing a formula

Experienced Excel users prefer to type formulas directly into a cell, in
the formula bar. This is a good technique for skilled users who are
familiar with the syntax of formulas (where to place commas and
parentheses, the order of arguments, and more). If you are not sure
of the syntax of the formula, type = and the name of the function, and
then press Ctrl+Shift+A. You will now see the syntax of the function.

When typing a function in the formula bar, a yellow Tip
box pops up, which contains the function’s syntactic |n 2002
structure.

[ Entering data into the function’s edit boxes
The edit boxes guide you in handling the syntax of functions.
Shortcuts for opening the Formula Palette

CtrlI+A — opens the Formula Palette immediately after typing the name of
the function. For example, type =SUM, and press Ctrl+A to open the
Formula Palette.

Shift +F3 — opens the Paste Function dialog box. Alternatively, use the
Paste Function icon (fx) on the toolbar.
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Tip — Enter a formula more quickly by
changing the names of the sheets

ey
() ™

When you enter a formula that links cells in different sheets in
the workbook and you do not use names for the references,
the formulas are long and often take up several rows. They are
also difficult to enter and edit.

If you rename the sheets with shorter names, such as 1, 2 or
3, the formulas will be shorter. When you are done
entering/editing, change the names of the sheets back to
meaningful names.

Copying a Formula, Relative and
Absolute Reference

Relative reference

When a formula is copied, the relative reference is used. Relative
reference is the distance, in rows and columns, between the reference
and the cell containing the formula. For example, in Cell A1, type the
number 100. In Cell B1, type the formula =A1. Cell B1 is one column to
the right of Cell A1. When the formula is copied from Cell B1 to Cell B10,
the distance between the reference and the cell containing the formula
remains one column. The formula in Cell B10 is =A10.

Absolute reference

Use the previous example, and select Cell B1. In the formula bar, select
the reference A1, and press F4. The result is =$A$1.

Copy the contents of Cell B1 to Cell B10. Notice that the formula does
not change; the formula reference remains constant as =$A$1.
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The F4 key

This is an important shortcut. The F4 shortcut, which deals with relative
and absolute references, has four states. Select Cell B1, and then select
the formula bar after the = sign. Press F4 several times. Notice how the
formula changes each time you press F4.

State 1 — absolute FA Microsoft Excel - Book1
reference to the column ] File Edt View Insert Format  Tools  Data
and row, =$A%$1. iz Elp S
TRIM > X J & =451
State 2 — relative A [ e =
reference (column) and 1 100, =431 J
2 200
absolute reference (row), -
=A$1 . 4
5
State 3 — absolute 5
refer_ence (column) and I 4 r H[4Sheetl /Sheetz £ 5F 4| | L[J_‘
relative reference (row), S .

=$A1.

State 4 — relative reference to the column and row, =A1.

Maintaining a relative reference when
pasting a formula

In many cases, you copy a formula from cell to cell when you want to
avoid changing the reference of the cell containing the formula. In this
case, use F4 to change the formula to absolute, copy it and paste it; then
use F4 to change the original formula back to relative.

Using F4 twice is annoying, but there is a way to avoid this repetitive
task. Copy and paste the formula from the formula bar back to the
formula bar, instead of from cell to cell.

For example: Cell A1 contains the formula =A$1. Select the text from
the formula bar (that is, select the formula) and press Ctrl+C (copy).
Leave the formula bar by hitting Esc or by clicking Enter or Cancel (click
the \ or the X to the left of fx on the formula bar). Select another cell in
the sheet and press Ctri+V.
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Ed Microsoft Excel - Book1
File Edit Miew Insert  Format  Tools  Data
Window -8 X
TRIM PR J A=A
A | e Zi
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2 200 J
3
4
3
6 -
WoAy v s Sheet1 ¢ Sheetz £ 5k 4] | HJJ
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Tip — Copy and paste a range of cells
containing formulas without changing the
relative reference

WA

Select a range of cells containing formulas. Press Ctrl+H to
replace the = sign with the # sign. After pasting the cells in a
different location, replace the # sign with the = sign.

Nesting Formulas

Nesting is the term for a formula within a formula.
For example:
In Cell A1, type the number 100. In Cell A2, type the number 200.
In Cell B1, enter the formula =SUM(A1:A2) (the result = 300).
In Cell B2, enter the formula =A2-B1 (the result = -100).
In Cell C1, enter the formula =IF(A1>A2,B1,B2).

When the formula in Cell C1 is calculated, the result depends on the
values in Cells A1:B2.
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In this case, the result in Cell C1 is —100.

Ed Microsoft Excel - Book1

Fil= Edit View Insert  Format  Tools  Data Window  Help

-0 X
C1 - fe =IF(ALl=A2,B1,B2)
B C e j
1 100 300 1008 -100 —]|
2 200 -100
3

4 -
4 4 » W[\ Sheetl ! Shest? f Sheet3 / 5he |4 | | L|JJ
Feady MUM A

Ed Microsoft Excel - Book1

File Edit YWiew Insert Format  Tools Data  Window  Help
- F X
01 - B =IF(AL=AZ, SUMATAZY, AZ-B1)
& T D B le
1 100 300 -100]| 100l —|
2 200 -100
3

| 7

4 4 » M['Sheetl  sheetz £ Sheetd £ she| 4| | i3
Ready MUM A

In the figure above, note the formula in Cell D1. The IF formula links
two formulas.

Excel’s method of nesting formulas is not particularly easy if you are
interested in using complex formulas.

For example: For Cell E1, type =IF in the formula bar, and press Ctri+A.

In the first edit box for the IF formula, select the relevant cells to enter
the formula A1>A2.

Notice the Name box to the left of the formula bar. The Name box has
changed to Paste Function. Click the little arrow on the right to open the
list of formulas, and select the formula SUM. In the first line of the SUM
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formula, select Cell A1. In the second line of the SUM formula, select
Cell A2. Click OK.

F3 Microsoft Excel - Bookl -0l =]

File Edit Wiew Insert  Formak  Tools  Data  Window  Help -8 X
TRIM X V[ =170

TRIM e E F G | HT

TEXT nchion Arguments
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COFFSET HF
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FMT :

e ATE Yalue iF_true | j‘J =

FRMT Yalue_if_False I ikJ =

MPEF.

WLOOKLP =

Mare Functions. .. ;hecks whether a condition is met, and returns one value if TRUE, and anotber value iF
o ALSE,
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12 Logical_test is any value or expression that can be evaluated to TRUE ar FALSE,
13

4 4 » M4 Sheetl
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Edit
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The IF box has disappeared. In the formula bar, click between the two
right-hand parentheses and type a comma (,); this brings back the IF
formula palette. Then type the formula A2-B1, and click OK.

This is clearly a tedious process. Chances are you will not manage to
nest complex formulas by this method without lots of practice.

Copying and pasting a formula within a
formula

This technique is easy. Copy and paste one formula into another by
copying the first formula from the formula bar. Then select a new cell,
click on the formula bar, and paste using Ctrl+V. See Copying a
Formula, Relative and Absolute Reference; the technique is similar.

For example:
In Cell D1, enter the formula =SUM(A:A)
In Cell E1, enter the formula =SUM(B:B)
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In Cell F1, enter the formula =SUM(D1+E1)

Copy and paste all the formulas into a single formula in a single cell,
instead of three formulas in three cells. For Cell D1, select in the formula
bar SUM(A:A) without the = sign. Press Ctrl+C and click the X to exit edit
mode for the cell. In the formula bar for Cell F1, select the reference D1,
and press Ctri+V.

Perform the operation again to copy the formula (without the = sign) from
Cell E1 to Cell F1, and paste over the reference E1. The result is a
single formula: =SUM(SUM(A:A)+SUM(B:B)).

Adding Statistical Formulas

Analysis ToolPak, Analysis ToolPak-VBA
21|

X,

When Excel is installed on
your  computer, not all
functions are automatically
. . [ Conditional Sum wizard Cancel
installed. The Analysis ™ Euro Currency Tadls
ToolPak contains about 100 Flntememssistant\fﬁﬂ Browes. ..
. . . Lookup Wizard =
functions. You must install this |-50|\,Brpp,dd_m
add-in if you want to use any

of its functions.

Ok

I Analysis ToolPak - YWEA

3

autormation, ..

You should also install the
Analysis ToolPak-VBA add-in.

This add-in includes VBA -~
functions that are useful in Analysis ToolPak

developlng appllcatlons in the Provides functions and interfaces For financial and
VBA programming |anguage_ scientific data analysis

Install both add-ins before
beginning to work in Excel.

Installing the add-ins

1. From the Tools menu, select Add-ins.
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Select both add-ins, Analysis ToolPak and Analysis ToolPak-VBA.
Click OK.

Now check to see if the functions included in Analysis ToolPak have
been installed. Press Shift+F3 (Paste Function) and select All. In
Select Function, notice the functions whose names are printed in
lower-case letters. You have installed these functions by installing

the Analysis ToolPak.

Array Formula

Use an array formula to create a I vicrossEse R R

) Fle Edt Vew Insert Fomat Took Data Window Help
formula that performs complex — T
calculations. B 7

| 3 | Par Number Quantity Price Tatal
For example: there are names I T
defined for three ranges: 3] s ars 13m Tt

18 | ABE1 413 18.00 7434

LEE ABBZ2 a17 20.00 10,340
Range A4:A12  Part_Number e . L1 -

| = ABBS 725 24.00 17,400

. 113 | | I

Range B4:B12 Quantity ] [ mrs

116 | [ rhe |
Range C4:C12 Price 2

|19 ABB3 15479
In Cell D16 is the array formula Ny —— |

={(SUM(Quantity*Price)}.

The formula returns the result of the Quantity range times the Price
range.

Tip — To enter an array formula, you must
hold down Ctrl+Shift while hitting enter.

N

For example:

Cell D19 contains the formula
={SUM(IF(Part_Number=C19,Price*Quantity,0)}.

The formula returns the result of the Quantity times the Price for part

number A663.
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Use the following technique to enter an array formula:

1. In any cell, enter the formula =SUM(Price*Quantity). Define Names
before beginning to enter the formula.

2. Press these three keys simultaneously: Ctrl+Shift+Enter.

3. The array formula is created when these three keys are pressed
simultaneously. In order to identify the array formula, brackets ({})
are inserted around the formula.

4. If you forget to hold down Ctri+Shift while pressing Enter, the
formula will evaluate to the VALUE! ERROR. If this happens, then
press F2 (Edit Cell), or use the mouse to select any character in the
formula bar.

The technical side of array formulas

An array saves calculations in the temporary memory, which are used
later in the calculation of the total. The ability to save results in the
temporary memory allows you to perform complex calculations such as
the one displayed.

Using array formulas to create links with
a change of direction

Select a range of cells in the sheet, & = = AT —

E3 Microsoft Excel - Book1

and press Ctrl+C. Select the last cell |, = o e Fg
2 Year Surn
in the sheet, right-click, and select |z == EE J
Paste Special. - B
) i ['Vear 1999 2000 2001
In the Paste Special dialog box, there === e
is a Paste link option. This option trmmmsm: Emarmmsia o  uf

allows you to paste link formulas into

cells. The Paste Special dialog box also has a Transpose option, which
pastes the data in the opposite direction (that is, horizontally to vertically,
or vice versa).
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Problem

You cannot select the Transpose option together with the Paste link
option. In other words, you cannot create a link while changing the
direction of the paste operation.

Solution

Use the TRANSPOSE function together with the array formula
technique to create links that change direction.

First, measure the number of cells in the selected columns and rows.
When selecting the range, notice the Name box.

Select range A2:B6, which has the name Range defined for it. The size
of the range is 4Rx2C - that is, four columns by two rows.

Starting with Cell A8, select a range whose size is 2Rx4C — that is, the
same size in the opposite direction.

1. Enter the formula =TRANSPOSE, and press Ctri+A.
2. Press F3, paste the name RANGE, and press Ctrl+Shift+Enter.

Creating a link between cells in a
workbook

Create a link between two workbooks. In Cell A1 in one workbook, enter
a formula that links to Cell A1 in another open workbook.

There are two ways to create links between cells. The first method is
between sheets in an active workbook, and the second is between a
sheet in one workbook and a sheet in another workbook. Here are two
methods for setting up a link between workbooks. The second method is
rarely used, but easier.

Method 1 Starting in the destination workbook:

In Cell A1, type the = sign. From the Window menu, select another
workbook, select Cell B1 in one of its sheets, and press Enter.



Formulas 101

Method 2 Starting in the source workbook:

Go to the source workbook. Copy Cell B1, and press Ctrl+Tab (to move
between open workbooks). Select Cell A1, right-click, and from the
shortcut menu, select Paste Special. Click Paste link.

Auditing

Auditing and tracing precedents (cells that contain formulas) or
dependent cells (cells that are referenced by formulas) can be a big
headache for the Excel user.

Using Names (see Relative reference and Absolute reference) is very
helpful in reducing the time spent auditing and evaluating precedent
cells. This section will show you ways to audit and evaluate formulas.

In Excel 2002, the relevant toolbar is called Auditing formulas. In Excel
97 and 2000, the toolbar is called Auditing.

Auditing formulas toolbar

Select one of the toolbars, and right-click. From the shortcut menu,
select Auditing formulas.

In Excel 97 and 2000, the Auditing toolbar does not appear in the list of
toolbars. Select one of the toolbars, right-click, and from the shortcut
menu, select Customize. Select the Toolbars tab, and select the
Auditing toolbar (or from the Excel menu, select Tools, Auditing
formulas).

Moving to a precedent cell / moving to a
dependent cell

Moving to a precedent cell

Select Cell A1 and click the Trace precedents icon on the Auditing
Formulas toolbar. Double-click the dotted arrow, and in the Go to dialog
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box, select the reference to which Cell A1 is linked. Click OK. See the

figure below.

Moving to a dependent cell

Select Cell A1 (without a formula), and click the Trace dependents icon
on the Auditing formulas toolbar. Double-click the dotted arrow, and

select the cell being referenced. Click OK.

Moving between linked cells in a sheet

Select a cell with a formula that is linked in the same sheet (for example,
=B10). Click the Trace precedents icon on the Auditing formulas
toolbar. Double-click the blue arrow between the linked cells to move

between the precedent cell and the dependent cell.
- Book2 g [l 3

Keyboard shortcuts to precedent and dependent

cells

Ed Microsoft Excel

@ File Edit Wew Insert Format Tools Data  window  Help -8 %
a1 - & =[Bookl]Sheetll$atl
& e R T
PardBurnb
SR Er;l S ﬁ GoTo

Go ka:

Reference:
|[Bocki Jsheet1 15a$1

Special. .. | (04 I Cancel |

4 4 » »]\Sheetl /Sheetz 7 Sheet3 £ Sheetd 4 she| 4|

Ready

MU

|

v

Precedent cell — Ctrl+[

Select all precedent cells — Ctri+Shift+{
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Press F2 or double-click a cell that contains links within the sheet. The
precedent cells are indicated in blue.

N

-

] '\\

Tip — Double-click a cell that contains links to
mark all precedent cells in the current
worksheet

From Tools, select Options, Edit.

Clear the Edit directly in cell option, and click OK.

Stepping into the Formula In 2002

Step into the formula’s calculations, one step at a time.

From the Tools menu, select Audit formulas, Evaluate formula, or
from the Audit formulas toolbar, click Evaluate formula.

E valuate Formula i E3
Reference: Evaluation:
Sheet31$ES1 = [IF{a1=42,41 482) ﬂ
Je|
To show the result of the underlined expression, click Evaluate, The most recent resulk
appears italicized.
Skep In She ot Close |

The Evaluate formula dialog box allows you to move between the

calculations in a formula. Click Step In to view a calculation that is part
of this formula.
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Handling Errors

Entering formulas into cells in Excel sheets is not foolproof. It is
impossible to completely avoid mistakes, but there are ways to keep
them to a minimum.

The method described in Nesting Formulas (see above) will help you to
create formulas inside other formulas. Combining the IF formula with the
ISERROR formula returns a calculation whose result is TRUE, if the
result of a calculation returns an error.

For example:
In Cell A1, type the number 100.

In Cell B1, type the formula =A1/A2. The calculation returns an error -
#DIV/0!

The error is created when you try to divide a number in a cell by 0 (A2).
To avoid displaying an error in a cell:

1. In Cell C1, enter the formula =ISERROR(B1). The formula returns
the result TRUE. That is, Cell B1 contains an error in the calculation
of the formula (the formula ISERROR is located in the category
Information in the Paste Function dialog box).

2. In Cell D1, enter an IF formula =IF(C1,0,B1).

3. Combine the formulas into one nested formula. From Cell C1, copy
the formula (without the = sign), and paste it into Cell D1 instead of
C1.

4. From Cell B1, copy the formula (without the = sign), and paste it
twice — instead of the digit 0 and instead of B1.

The result — one nested formula: =IF(ISERROR(A1/A2),0,A1/A2).
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Function Arguments
IF
Logical_test [ISERROR(41/42) T = TRUE
Value_if_true ||:| ik_l =0
Value_if_False [a1)02 ] = #p1v/on
=0

Checks whether a condition is met, and returns one value if TRUE, and another walue if
FALSE,

¥alue_if_false is the value that is refurned if Logical_test is FALSE, If omitked, FALSE is
returned.

Formula result = 0

Help on this function (04 I Cancel

Marking Cells Containing Errors

Mark cells containing errors so that they can appear in color, be easily

identified, or be deleted.

Go To Special 2] x]
Technique 1 Select
£ Comments " Row differences
. " Constant:  Column diff
1. Press F5, or from the Edit menu, select worue oo
Go To |_ ~ Dependents
" [T @ Direct only
. . . ™ Logicals € alllevels
2. Inthe Go To dialog box, click Special... ¥ Emors " Lastcol
€~ Blanks " yigible cells only
3. Select Fo rmulas, Errors. " Currertregion ¢ Conditional farmats
€~ Current array " Data validation
H " Objects L
4. Click OK. o

|
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Technique 2

Use conditional formatting to mark and/or color cells containing
errors.

1. Make A1 be the active cell. Press Ctrl+A to select the sheet.
2. From the Format menu, select Conditional Formatting.

3. In Condition 1, select Formula Is.
4

In the formula box, type the formula =IsError(A1). Now click Format,
and select the desired properties.

5. Click OK.

Tracing errors In 2002
In Cell A1, type the number 100.

In Cell B1, type the formula =A1/A2. The result of the calculation
returns the error #/DIV/0!.

Select Cell B1 with the error, and click the Error checking icon (the
first icon on the left on the Auditing formulas toolbar.

Smart tag In 2002

The smart tag for handling errors is created automatically in the cell
whose calculation returned an error. Open the shortcut menu by
clicking the small Smart tag arrow.

Through the shortcut menu, you can get an explanation of the type of
error in the formula, edit the formula, ignore errors, and view the
evaluation steps by selecting Show Calculation Steps...
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B Nicrosoft Excel - Book1 18]
E) He it Vew Dset Fymat Dods Data Window dep Type 3 question ‘ot help 5] fm
DEHa 83 BRI v BQALHTE AW 0 ¥ 1),
#10 3 B& JE.
b1 - A =pstji2
. EEEN R e e
o T 0 I

Divde by Zer Error
Heb onthis errar
Show Calulaticn Steps.

Tgrore Eror

Edtir Ernua 3o

Eor Chedirg Jrtics.

show Fornuls Audiing Toober

4 b W\ SFeett [ Srest ) sheets {SFeets { sreets

Reaty

Ao | SEOCCGBEED || ootmar [Frorr Bpoune

Emor Checking

[BOECE =

~Error in cell B1

=n1jnz

~Divide by Zero Error

_ Help on khis errar

Show Calculation Steps. ..

The Farmula or Function used is dividing by
zero or emply cells,

Ignore Errar

Edit in Earmula Bar

Options. ..

Previous

[exk

Circular References

A circular reference is created if you enter a formula into a cell and the

cell is its own precedent.

The Circular Reference toolbar (shown on next page) indicates the
reference of the cell containing the circular reference. If you glance at
the formula or the Status bar (at the bottom of the sheet), you can

pinpoint the source of the error and correct it.
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BB oo Evoet-Bookt = EY
E File Edit Wew Insert Format  Tools Data  Window Help Type aquestion for help =2 8 X
NEES ERY BB v @@= A SIS AW - 2
G R A0 G EERA.
03 - fe =SUM(D:D)

i : 100 l' #DI?MD! | TR(EJE l' I - : ’ 3
> $0$3 - =EEm A

12 | ol il |

% Formula Refers to Empty Cells

e Trace Empty Cell

I Help on this errar

% Ignore Errar

| 10 | Edit in Formula Bar

i; Error Checking Options, .,

[ 13 | Show Formula Auditing Toolbar =
W e w[%, Sheetl 7 Sheet? 3 Sheet3 / Sheetd / Sheet5 / (Kl | L[J_‘
Ready Circular: D3 UM i

Iteration

You can use a circular reference intentionally by using the Iteration
box. Iteration enables circular calculation and offers a method to control
it.

For example:
: ‘) He Edt View Insert Fomat Took Dats  Window  Help Type aquestion for help 9| m 8 X
- B1 - A =B3-B2
Value-added tax e e
i 8547 l«—— =p3bz
(VAT) gross-up =] oriesie—— =wm J
[ =] 100.00
formula -
6|
7
1. In Cell B1, |=
2 -
type the 4 4 b w\Sheet1 {Sheetz [ Sheetd /[ Sheet+ { SheetS i shesté { shest? A shed|d| | LUJ

formula =B3-B2 (the result of this calculation is a total without VAT).
2. In Cell A2, type the VAT percent (%) 0.17.

3. In Cell B2, type the formula =A2*B1 (calculates the VAT amount).
Click OK to dismiss the circular reference warning.

4. In Cell B3, type the amount 100.
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A circular reference is created in Cell B1. The calculation of the amount

without VAT is
g Color | International I Save I Errar Checking I Speliing | Security |
co ndltloned u po n th € e Calculation Edit I General I Transition I Custam Lists | Chart

calculation of VAT in Caculation

@& pukomatic € Marual Calc Mow (Fa)
Ce l I Bz . " Automatic except tables ¥ Recalculate before save —I
Calc Sheet |
Select the Iteration box
. v {Iteration
tO perform a circu Ia r Maximun itgrations: IIUU Maximum change: IEI.EIU]
Calculatlon . ‘workbook options
¥ Update remote references W Save external link values
F rom th e Too I S menu ™ precision as displaved ™ accept labels in Formulas
. ! I~ 1904 date system
select Options. In the
Calculation tab, select |
the Iteration box and
click OK.

Excel allows you to define the number of iterations (number of times the
formula is calculated) until the exact calculation is performed.

Links Between Workbooks

Creating links between workbook sheets

[ Links are created by formulas.

[ Links are created by moving sheets with Names from one workbook
to another. When you move or copy a sheet by selecting its tab,
right-clicking, and then selecting Move or copy from the shortcut
menu, the sheet with Names that you defined is moved from the
active workbook to a new workbook. This results in the creation of
unwanted links in the new workbook.

[ Broken links are created when the location of the precedent
workbook is changed on the hard disk. When you save a workbook
that is linked to another workbook and then move or copy the linked
workbook to another folder on the hard disk, the first workbook still
saves the original reference on the hard disk.
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Tip — quick creation of link formulas

N

Use Paste special to create links automatically. Copy a range
of cells with data, select a cell in another sheet or workbook,
right-click, and select Paste special. Then click Paste links.

Canceling the message about creating
links when opening a workbook

1. From the Tools menu, select Options, and then select the Edit tab.

2. On the Edit tab, clear the selection of the Ask to update automatic
links box.

The Edit Links Dialog box

From the Edit menu, select Links.

Excel 2002 offers new solutions for handling the

problem of links between files. In 2002
Edit Links 7]
Source I Type I Update I Skatus I Update VYalues |
iookl.xls  Worksheet & SOUFCE is OpEn
Book3 warksheet 4 SOUrCE is Open Zhange Source. .. |
Books Worksheet A SOUFCE is open
Books Worksheet A SOUrce is open Open Source |
Break Link |
Check Status
Lacation: E:\ExcelBookEnglishiChapter 7
Ikem:
Update: @ fikomatic = Manual
Startup Prampt.., | Close |
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Start Prompt
e i In 2002

Click the Startup Prompt button, and define the method of opening

linked fil: Startup Prompt EE

‘\When this workbook is opened, Excel can ask whether or nok ko update
limks ko other workbooks,

® [ et Users choose ko display the alert or not
" Don't display the alert and don't update automatic links
" Don't display the alert and update links

(04 I Cancel

Break Links

Select the type of link you want to break, and click Break links. The
links between workbooks are broken, and the linked formulas are

Caution

Double-check and make a backup copy of the workbook
before breaking the links.
Changing a source

Changing a source allows you to change the location of the workbook on
the hard disk or to exchange the location of one workbook for another.

1. Select the workbook in the old location.
2. Click Change source.

3. Select the workbook that should be linked in the folder you have
opened.

4. Click OK. The location of all linked formulas will change.
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Changing links and deleting unwanted links

Stage 1 — Check to see if there are any links that were
created by Names

1.
2
3.
4

5.

Select a cell in the sheet.

Press F3, and click Paste list.

Check the list, and identify the Names you want to delete.
Press Ctrl+F3.

Select the Name to be deleted, and click Delete.

Stage 2 — Check the link in the sheet and find the links
that can be deleted

1.
2.

3.
4.

Press Ctri+F.

In the Find box, type a square bracket ([). Every externally linked
formula has a square bracket.

Start the search for formulas one cell at a time.

Delete unwanted and unnecessary formulas (do this with care).

Stage 3 — Check the data consolidate dialog

1.

From the data menu, select Consolidate. This dialog remembers the
last consolidation.

If any items in the All References box point to the undesired link,
highlight them and click Delete.

Stage 4 — Check the link box

1.

2
3.
4

From the Edit menu, select Links.
Select the name of the workbook whose links you want to delete.
Click Change source.

In the folder, select the workbook you are currently working in (that
is, link the workbook to itself).

Click OK.
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Stage 5 — Save the workbook under a new name

If a linked workbook exists and it is not mentioned in the Links box,
there is a solution. Save the workbook that has links under the name of
the workbook to which it is linked (according to the Links box). The links
are automatically deleted (the new workbook is linked to itself). Save the
workbook again under whatever name you wish.

Deleting Formulas, Saving
Calculation Results

Using formulas does not mean you must keep them after performing
calculations with them. Saving a large number of formulas has several
disadvantages: it requires a large amount of memory; workbooks have a
large file size; links are problematic; and more.

It is vital to delete formulas without deleting the necessary calculated
values, whether to solve some of the problems mentioned above or to
send reports to other people who should not see the calculation methods
that were used.

Deleting formulas, maintaining calculated
values

1. Copy the cells with the formulas.
2. Right-click, and from the shortcut menu, select Paste special.

3. In Paste, select Values and click OK.

Tip — Quickly delete the formula without
} deleting the calculation result

Ay
() ™

Select a cell containing a formula, press F2 and then press F9.
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Deleting formulas and pasting values
using a single line of code and a keyboard
shortcut

Record a macro adding a Shortcut Key and save the macro in a Personal
workbook. Enter the following code to the macro you created:

Selection.Formulas=Selection.Value

Selecting Cells with Formulas

. Go To Special
Use the Go To dialog box to select el 2]
. Select
formulas in a sheet to delete, to protect = Commants ¢ Pow dffsrences
(See below), or to color. " Conskant € Column differences
) & F " Precedents
1. Press F5, or from the Edit menu, o e
select Go to. V¥ Text @ Direct only
. . . V¥ Logicals £ all levels
2. In the Go to dialog box, click Special. = Errors £ Last ool
e = yisi
3. Select Formulas. Blanks Visible cells only
" Currentregion ¢ Conditional Formats
4. Click OK. " Current array " Data validation
" Objects @& al
Only cells that contain formulas are " Same

selected in the sheet. ok | caneel |

Identifying and Formatting Cells
with Formulas

Excel does not provide a formula that identifies formulas. VBA has a
function called HasFormula. The solution is to create a custom function
(see explanation at end of chapter) to identify a cell containing a formula.

Function FormulalInCell (Cell) As Boolean
FormulaInCell = Cell.HasFormula

End Function
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Use the technique described below to combine the Get.Cell formula with
conditional formatting to format cells containing formulas. After creating
the formula FormulalnCell, combine it with Conditional Formatting.

Conditional Formatting

ondition 1
IFnrmuIa Is j |=FormuIaInCeII(.ﬂ.1)

Preview DF_Fprm_at ko use AaBbCCvyZz
when condition is true:
@l Add == | Delete. .. | [l 4 | Zancel I

Combining the Get.Cell formula and
conditional formatting to format a cell
with a formula

Excel includes the macro language XLM. This macro language has a
function called Get.Cell. Use this function to identify a formula in a cell by
combining it with conditional formatting. The technique is described
below.

1. Select a cell in the sheet, and press CtrI+F3.
2. In the Define Name dialog box, type the name FormulalnCell.

3. Type the formula =GET.CELL(48,INDIRECT(“rc’,FALSE)) in the
Reference field.
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Define Hame

Mames in workbook:

|F|:|rmuIaInCeII K
Formu

Refers ko
|=GET.CELL(48, INDIRECT("RC", FALSE))

4. Select all the cells in the sheet by pressing Ctrl+A.

5. From the Format menu, select Conditional formatting.
6. In Condition 1, select Formula is.

7. In the formula box, type =FormulalnCell.

8. Click Format.

9. From the Font tab, select the color yellow, and click OK.

10. Click OK.

Conditional Formatting 2=

ondition 1

IFormuIa Is j |=FormuIaInCeII

Preview DF_Fprm_at to use AaBbTcYyZz
when condition is true:

Add == Delete. . ok | Cancel |
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Protecting Formulas in Cells

. Format Cells 2| x|
Protecting a cell or a group of

cells prevents writing, editing or
. . ¥ Lacked
deleting the cell, or damaging the = ® s
formula. Two conditions must be
Locking cells or hiding formulas has no effect unless the
met tO p rOtect a ce | I . the Ce” m USt waorkshest is protected, To pratect the worksheet, choose
Protection from the Tools menu, and then choose Protect

be locked, and the sheet must be e Apasswardi eptianal
protected.

Mumber I Alignment | Fonk I Eorder I Patterns  Protection |

cancel_|

Locking, the first
condition

Select a cell in the sheet and press Ctrl+1. In the Format Cells dialog
box, select Protection. Select the Locked option.

Protecting a sheet, the second condition

From the Tools menu, select Protection, Protect sheet, and click OK
(password is optional).

Protecting formulas

Protecting formulas requires isolating cells with formulas from the rest of
the cells in the sheet, locking them, and then protecting the sheet.

Stage 1 — Canceling the locked format of all the cells in
the sheet

1. Select all the cells in the sheet by pressing Ctrl+A.

2. Press Ctrl+1.

3. Select the Protection tab.

4. Clear the selection of the locked option.

5. Click OK.



118 chapter 7

Stage 2 — Selecting cells with formulas
1. Press FS.

2. Click Special.

3. Select the Formulas option.

4. Click OK.

Stage 3 — Locking cells with formulas
1. Press Ctrl+1.

2. Select the Protection tab.

3. Select the Locked option.

4. Click OK.

Stage 4 — Protecting the sheet
1. From the Tools menu, select Protection, Protect sheet.

2. Click OK (password is optional).

The Protect Sheet dialog
box in Excel 2002 allows In 2002
you to select various x|

i ) Protect Sheet
topics for protection.
¥ Protect worksheet and contents of locked cells

In Allow all users of this Passward bo unprotect sheet:
worksheet to... in the ||
Protect Sheet dialog box,
select the desired options.

Allov all users of this worksheet ko

[l Select locked cells
V¥ Select unlocked cells
[~ Format cells

™ Faormat columns

[ Faormat rows

[ Insert columns

|_ Insert rows

[ Insert hyperlinks

[ Delete columns

™ Delete rows ;I

[0 4 I Cancel I
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Displaying a Formula in a Cell and
Printing Formulas

Displaying

formula syntax

The result of calculating a formula (value) appears on the screen and
can be printed by clicking the Print icon. However, you can usually view
the syntax of a formula only by selecting the cell. To see all formulas on
the sheet, press Ctrl+~ (the ~ sign is located to the left of the number 1
on the keyboard), or from the Tools menu, select Options. Then select

the View tab, and s

elect the Formulas option.

To return to the normal view, press Ctrl+~ again.

Printing the formula syntax

Use the usual method of printing in Excel to print from the sheet while
formulas are displayed using Ctri+~.

H 2 Microsoft Excel - Book2 i ] P
@ File Edit W¥iew Insert Format Tools Daka  Window  Help Type aquestion forbelp = o @ X
F19 - #
| A | B | C D =
1] =
| | 2 |Year Sales
| 3 [1999 9281
| 4 |2000 B452
| 5 |2001 7582
| B |Tatal =5UM(B3:E5)
7
E=TRANSF’OSE(Range) =TRANSPOSE(Range) =TRAMNSPOSE(Range) =TRAMSPOSE(Range)
| 9 |=TRANSPOSE(Range) =TRANSPOSE({Range) =TRANSPOSE(Range] =TRAMSPOSE({Range)
10 -

M 4 » H[}Sheetl
Ready

P R R ol

R s
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Using VBA to Create and Add
Functions to the Function Wizard

When you work in Excel, there will be times when you need to create a
complex custom formula.

Take, for example, a formula to calculate the net salary from a gross
salary. This is a very complex calculation, as this type of formula is made
up of fixed pieces of data, including income tax schedule, social security
laws, tax credits and additional credits and deductions.

Another example would be a formula for calculating sales commission
that varies depending on the level of sales, formulas for converting
currency, conversion of weights and measures (a Convert function
already exists in Excel), or a conversion of text. See Chapter 16,
Importing Text Files.

VBA formulas can be used for several reasons, one of which is to create
custom functions for your personal use. You can add these functions to
the Function Wizard.

Custom functions, example and
explanation

Create a function called Add to total two numbers in different cells. The
function has two argument boxes.

Function add (MNuberl, NumberZ) Az Integer
Add = Numberl 4+ MNwmber
End Function

Formula structure:
[ Function name = Add

[ The function arguments are placed in parentheses. The above
example has two argument boxes.
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[ The last piece of the formula, As Integer, defines the value of the
variables as a whole number. See the explanation in the Variables
section of Chapter 28, Other VBA Techniques.

[ Function calculation — where the function receives the results of the
calculation and returns the result.

Location to write and save function:

We advise saving the functions in an active workbook or personal
workbook. See the Storing a macro in a personal workbook section of
Chapter 26, Running a Macro.

Activation of function:

1. Type numbers into cells A1:A2.

2. Select cell A3 in the same sheet.
3. Press Shift+F3 (opens the Paste Function dialog box).
4. Select the User Defined category.
5. Select the Add function.
6. In the first argument box, select cell A1.
7. In the second argument box, select cell A2.
8. Click OK. _
Insert Function 2]
Search For a Function:
Ilrciea‘:. brief description of what you want ko do and then Go
Function Arguments 2] x] Or select a cabegory: |User Defined -
add Select a Function:
Number1 [&1 E2 S —
Number2 [&2] El-2s 1s5hiared
=500
Ha help avallabls,
=
R Add(Number1,Number2)
Mo help available.
Farmula resuk = 500
Help on this function Cancel Help on this function Cancel
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Using a function to calculate accrued
income tax from gross salary

This function will calculate the tax payable based on gross salary,
marginal tax schedule and credit point schedule.

The function has a single edit box — gross salary (income).

Schedules — the values are defined using a constant variable, Const,
which cannot be changed when the function is operating. The constant
variables are loaded into memory cells when the function is operated.

Case - like IF, the function allows you to check a large number of
instances.
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Function IncoweTax (Income) As Single f M
Marginal
Const D1 As Double = 1940 Tax
Const DZ As Double = 3890 Schedule
Const D4 As Double = 15560 \ _J
Const P1 As Double = 0.1 4 N
Const P2 As Doubkle = 0.2 %
Const P3 Az Double = 0.3 Marginal
Const P4 As Double = 0.45 Tax
Const P5 Ais Double = 0.5
g /
Casel = L1 * F1 f
Cased = (D2 - D1) * P2 + Casel Calculation of
Cased = (D3 - D2) * P3 + Casel Accrued
Cased4 = (D4 - D3) * P4 + Casel Tax
Case5 = (D5 - D4) * PS5 + Cased
SFelect Case Income K
Case 0 To D1 / ™~
IncomeTax = Incoms * P1
Case (1 + 1) To D2
IncomeTax = [(Income - D1) Fz + Casel Amount
Case (DZ + 1) To D3 to be
TncomeTax = [(Income — D2) P3 + Casez returz‘_ed
Case (D3 + 1] To D4 atCCOr ing
IncoweTax = [(Income — D3) P4 + Casel ,0 gross
Case Is > D4 Income
IncomweTax = [(Income — D4) FS + Cased
End Zelect
End Function \ /
Function Arquments | 7] x|
IncomeT ax
[ Income |B4| ] = 7500
= 1RE7
Mo help available,
Income
Formula result = 1,667.00
Help on this Funckion Ok I Cancel







